Why are my report modules not displaying data?

In some instances, modules in your Branded Report might not show any data or may not have updated if you've recently had to reconnect or similar. You may also find that Quick Reports modules are not updated for the same reason.

When this happens, there are a couple of things you can do to correct this (other than for Instagram reporting, please see jump link on the right):

 

General Troubleshooting Steps

1. (Branded and Quick Reports) Do you have enough activity on your social site for the data to be generated?

r1.png

r6.png

Examples of possible error messages displayed

If there is very little or no activity/engagement at all on the relevant social channels or pages for your selected time period, we may not be able to display data until there is enough new activity.

Please try adjusting the filter for the time period or look to generate more activity on your page. You may want to check out our Insights blog for ideas to help you maximise engagement with your audience.

Tip:
Users on a Traction plan and above, have the ability to download and use raw reporting data as a CSV or HTML file, to check your monthly data day by day. Please see this article for more information and this article of how to create your own charts using this data!

 

2.(Branded and Quick Reports) Does your profile need to be re-connected?

Facebook  

r2.png

 

LinkedIn

r3.png

There will be an error message shown, if the profile you are trying to pull reporting data for, is disconnected and needs to be re-connected. A profile can be disconnected by the social sites for various reasons.

To reconnect the profile, please see the following articles:

Please Note:
LinkedIn expires access tokens every 60 days, for security reasons, so you will need to reconnect your LinkedIn profile every 60 days.

 

3. (Branded Reports) Have you added a module to your report before re-connecting the related profile or after deleting a profile you are looking to get analytics for?

If you had the module added to your report previously, and then you re-connected or re-added the profile after deleting it, the module will likely not generate data or will not update its current data.

This is because the module may still be trying to pull data from the disconnected or old profile. Once you've reconnected or re-added the relevant profile, please proceed to the next step.

 

4.(Branded Reports) Have you tried refreshing the module? 

r5.pngQuick reports 

rep8.png

Custom reports

Sometimes you will find that refreshing the module by clicking the circular arrow icon (quick reports) or the Refresh option by clicking on the cog (custom reports) will update the module.

If after refreshing the module, your module still shows incorrect data or no data at all, please proceed to the next step. 

 

5.(Branded Reports) Have you tried removing the module from your report, then re-adding it? 

r4.png

Removing and re-adding a module should force the module to start pulling data from the correct profile if you've re-connected or re-added a profile after deletion.

If you are still having issues with a specific module after going through the above steps, please log a ticket using the option in this help centre with a brief outline of the module/s that are not updating and the name/s of the related reports we'll take it from there.

 

Channel specific Troubleshooting steps

Google Analytics reports

In the case of Google Analytics custom and quick reports, the account can be disconnected by Google and will show that it needs to be reconnected. This is especially likely to happen if you're managing more than 10 websites within 1 Google account.

Important Note:
If you have more than 10 websites linked to Google Analytics, you would need to separate them into other Google user accounts. For example, if you have 20 Google Analytics pages you're managing, you would need to separate them equally between 2 Google user accounts.
If you're accessing a quick report for Google Analytics, it will prompt you to re-select the Google Analytics account.

To re-connect your Google Analytics account for a custom report, please follow the steps below:

 

g1.png

1. Go to your custom report you wish to have Google Analytics modules included within Sendible in Measure > My reports.

 

g2.png

2. Select the module that's disconnected and not displaying data.

3. Remove the module from the report.

 

g3.png

4. Go to Add module and select the Google Analytics tab, then click on the + plus icon next to the module you need to re-add.

 

g4.png

5. You will be prompted to log into your Google account.

 

g5.png

6. You will be asked to grant access for Sendible to your Google Analytics data. Press OK.

 

g6.png 

7. You will then need to select the Google Analytics account and website to retrieve the data from. Once you click Add, the module will be added to your report.

Please Note:
If you need to re-connect more than 1 module, you will need to go through the above steps for each module.

 

Related articles

Have more questions? Submit a request